For many years we have strived to support older versions of PHP in order to cater for more users’ needs.
Going forward, this has become a limitation which is no longer worthwhile.
From the next core version of WP RSS Aggregator, version 4.13, the plugin and its add-ons will require PHP 5.4 or newer.
We announced this in a notice within the plugin itself in the current version, 4.12.1. As of version 4.13, if you are using an older version of PHP on your site, the plugin will deactivate itself in order not to cause any errors.
Lastly, if your host is still using anything lower than PHP 5.4, please request that they update to a newer, supported version. It’s either that, or we recommend moving host to a more reliable solution. We have some recommended web hosts here.
PHP 5.3 is 10 years old and has not been supported for a long time. We will continue to support older version where we can, however, going forward, the aim is to contribute to a safer, faster web. One way of doing that is by using newer technologies.
If you have any questions about this or something else, our support channels are always open and the team is waiting to get you the answers you need.